PernixData FVP in the Home Lab Part 2.

So after I have been running vFRC on my Home Lab for a few weeks, I’m now going to install PernixData FVP instead.

Since that needs an SSD for it self, the first task will be to uninstall/unconfigure vFRC, which seems to be a bit tedious. Guessing I could just unpresent the disk, but not sure vSphere would like that very much, so I’m going to first remove the caching Ive setup for each of the VMDK’s in my home lab. Meaning, Edit-Settings, Expanding each Hard disk and setting the Virtual flash read cache to 0(Zero) GB.

vFlash

 

After that I have to remove the Virtual Flash Host Swap Cache I’ve setup for vSphere.

vflash cache

And lastly I will remove the SSD from the Virtual Flash Resource Management page. After that, the system is ready for FVP installation. Figuring that it might be a good idea to at least scan the Install guide from PernixData before installing.

First up it needs a Windows server, either 2008 or 2012, with 8Gb of Ram for the management server. So for a Home Lab that means it takes at least 16Gb of Ram for FVP, as the smallest vCenter is also 8Gb of Ram. That seems a bit much but it remains to be seen how much ram it actually will use when it has been running for a few days.

I’m going for a 2012 R2 64Bit windows installation, and I can already feel that my Home Lab is slower now that I have uninstalled vFRC. So really hoping FVP will give a bigger boost.
First you have to install the Host Extension, which you copy to a datastore that the ESXi host can see. then just enter your host into maintenance mode, ssh in, and fire off a short esxcli command. And wait …. it took around 3 minutes in which nothing happened, but then.

hostextension

I’ve run into some problems with my VCSA, since I can’t get it to join my domain. And can’t seem to find anyone with the same problems, thinking its DNS/or something else. After I have spend a few hours searching for this problem, which seems to also be on Centos and Ubuntu distributions of linux, but none of their solutions worked. So I gave up and installed a Windows server 2012 R2 (with around  2 TB of updates to be installed afterwards) and installed a windows vCenter instead of the VCSA. Joining that to my windows AD was a piece of cake, and the FVP management server installed perfectly.

However, the plugin for vCenter both Web and C# didnt work. It took me some time to figure out why. My vSphere runs 5.5 but I had installed a vCenter 6.0 which is still not supported by PernixData. Will try to contact them to see if there is a workaround, or I have to reinstall my vCenter to a 5.5. More to follow in part #3 🙂

 

 

 

 

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

vFrank

Essense of virtualization

vTerkel

A Virtualization Blog

Go Software Defined

vSphere - The foundation of every Datacenter.

blog.scottlowe.org

The weblog of an IT pro specializing in virtualization, networking, cloud, servers, & Macs

Virtual Geek

A Virtualization Blog

Perfect Cloud

Virtualize everything!

Yellow Bricks

by Duncan Epping

%d bloggers like this: